summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/base-files/etc/diag.sh
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 17:55:25 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 17:55:25 +0000
commit8d8a937272fd03902d4e40888efcf3ff707c0d57 (patch)
treec4f6626928a3dad1d94cc2e9f4ab9ef77429d453 /target/linux/ar71xx/base-files/etc/diag.sh
parent795cc23a08b7e70743a125bc4f9c2fa7d284a26c (diff)
downloadmaster-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.tar.gz
master-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.tar.bz2
master-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to trunk
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox into trunk (or 'Designated Driver' :D ). Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners on 15.05. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> SVN-Revision: 47234
Diffstat (limited to 'target/linux/ar71xx/base-files/etc/diag.sh')
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index b2f77a007d..1375f38b79 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -227,6 +227,9 @@ get_status_led() {
smart-300)
status_led="nc-link:green:system"
;;
+ minibox-v1)
+ status_led="minibox-v1:green:system"
+ ;;
oolite)
status_led="oolite:red:system"
;;