summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-09 23:32:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-09 23:32:46 +0000
commit0be8dd36dcb81e1395a43563aa89f55ab18873dd (patch)
tree93d578f4d1aedea875382a4163fd455bae607ca1 /target/linux/ar71xx/Makefile
parent0fb3475eccdcbeb76be034b0a722e4687d0e5fa0 (diff)
downloadmaster-31e0f0ae-0be8dd36dcb81e1395a43563aa89f55ab18873dd.tar.gz
master-31e0f0ae-0be8dd36dcb81e1395a43563aa89f55ab18873dd.tar.bz2
master-31e0f0ae-0be8dd36dcb81e1395a43563aa89f55ab18873dd.zip
ar71xx: set mips16 support, tune cflags for 34kc (works well on MIPS 24K as well, but helps a lot for 34K and 74K)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36600
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 83b238e584..600b21d430 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
ARCH:=mips
BOARD:=ar71xx
BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs jffs2 targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
LINUX_VERSION:=3.8.12