summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-4.1/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-05 21:32:44 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-05 21:32:44 +0000
commit7f3182da169223b848d6b4c9a34c3d650de32312 (patch)
tree581c224dfe199a248cb2eab1b0aa83cf8e992755 /target/linux/ar7/patches-4.1/120-gpio_chrdev.patch
parent62cdc72fb87773188e761e6ebde2c104831b6a64 (diff)
downloadmaster-31e0f0ae-7f3182da169223b848d6b4c9a34c3d650de32312.tar.gz
master-31e0f0ae-7f3182da169223b848d6b4c9a34c3d650de32312.tar.bz2
master-31e0f0ae-7f3182da169223b848d6b4c9a34c3d650de32312.zip
ar7: add linux 4.1 support
Compile tested only. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46186
Diffstat (limited to 'target/linux/ar7/patches-4.1/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-4.1/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-4.1/120-gpio_chrdev.patch b/target/linux/ar7/patches-4.1/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..1468ca3212
--- /dev/null
+++ b/target/linux/ar7/patches-4.1/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -461,6 +461,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o