summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.3/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:39 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:39 +0000
commitdd884a6b738a85c9db305c17fe5fedd1710f9d23 (patch)
treeda17012ec0c7a1373ae10ef9951403c463d04cfb /target/linux/ar7/patches-3.3/120-gpio_chrdev.patch
parente85a44f11ba3d975789e1b8c8032b7d5197052c0 (diff)
downloadmaster-31e0f0ae-dd884a6b738a85c9db305c17fe5fedd1710f9d23.tar.gz
master-31e0f0ae-dd884a6b738a85c9db305c17fe5fedd1710f9d23.tar.bz2
master-31e0f0ae-dd884a6b738a85c9db305c17fe5fedd1710f9d23.zip
ar7: add 3.3 support
SVN-Revision: 31615
Diffstat (limited to 'target/linux/ar7/patches-3.3/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-3.3/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.3/120-gpio_chrdev.patch b/target/linux/ar7/patches-3.3/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..006cef4d5b
--- /dev/null
+++ b/target/linux/ar7/patches-3.3/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -478,6 +478,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o