summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-09 12:12:30 +0000
committerJohn Crispin <john@openwrt.org>2015-02-09 12:12:30 +0000
commit9f0f80faacff55e9e909b87328fc0def14290562 (patch)
treecc7d2b74e9645ac723ef45db443ff6b4b0aeda14 /target/linux/ar7/patches-3.18/120-gpio_chrdev.patch
parent5c8b8b36e1812feb055fc8574fe03156fa1efcb3 (diff)
downloadmaster-31e0f0ae-9f0f80faacff55e9e909b87328fc0def14290562.tar.gz
master-31e0f0ae-9f0f80faacff55e9e909b87328fc0def14290562.tar.bz2
master-31e0f0ae-9f0f80faacff55e9e909b87328fc0def14290562.zip
ar7: add 3.18 support
this is only compile tested Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44344
Diffstat (limited to 'target/linux/ar7/patches-3.18/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-3.18/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch b/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..beb0052ca1
--- /dev/null
+++ b/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -452,6 +452,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o