summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.23
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-19 07:06:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-19 07:06:35 +0000
commitb0b3bc5f009249df74c13ec0dc6087cf1943b318 (patch)
tree04584132f5c79a71a972bf9597a9c1d3085f9bbb /target/linux/ar7/patches-2.6.23
parentd132c5f42c208e4ab1bb3be0a7503262ee7e4059 (diff)
downloadmaster-31e0f0ae-b0b3bc5f009249df74c13ec0dc6087cf1943b318.tar.gz
master-31e0f0ae-b0b3bc5f009249df74c13ec0dc6087cf1943b318.tar.bz2
master-31e0f0ae-b0b3bc5f009249df74c13ec0dc6087cf1943b318.zip
refresh kernel patches
SVN-Revision: 11196
Diffstat (limited to 'target/linux/ar7/patches-2.6.23')
-rw-r--r--target/linux/ar7/patches-2.6.23/100-board_support.patch32
-rw-r--r--target/linux/ar7/patches-2.6.23/110-flash.patch24
-rw-r--r--target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch16
-rw-r--r--target/linux/ar7/patches-2.6.23/130-vlynq.patch18
-rw-r--r--target/linux/ar7/patches-2.6.23/140-watchdog.patch16
-rw-r--r--target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch16
-rw-r--r--target/linux/ar7/patches-2.6.23/210-phy_fixed.patch16
-rw-r--r--target/linux/ar7/patches-2.6.23/500-serial_kludge.patch24
8 files changed, 82 insertions, 80 deletions
diff --git a/target/linux/ar7/patches-2.6.23/100-board_support.patch b/target/linux/ar7/patches-2.6.23/100-board_support.patch
index 9269a13a30..681a1a9843 100644
--- a/target/linux/ar7/patches-2.6.23/100-board_support.patch
+++ b/target/linux/ar7/patches-2.6.23/100-board_support.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/arch/mips/Kconfig
+Index: linux-2.6.23.17/arch/mips/Kconfig
===================================================================
---- linux-2.6.23-rc6.orig/arch/mips/Kconfig 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/arch/mips/Kconfig 2007-09-21 16:24:11.000000000 +0800
-@@ -15,6 +15,22 @@
+--- linux-2.6.23.17.orig/arch/mips/Kconfig
++++ linux-2.6.23.17/arch/mips/Kconfig
+@@ -15,6 +15,22 @@ choice
prompt "System type"
default SGI_IP22
@@ -25,11 +25,11 @@ Index: linux-2.6.23-rc6/arch/mips/Kconfig
config MACH_ALCHEMY
bool "Alchemy processor based machines"
-Index: linux-2.6.23-rc6/arch/mips/kernel/traps.c
+Index: linux-2.6.23.17/arch/mips/kernel/traps.c
===================================================================
---- linux-2.6.23-rc6.orig/arch/mips/kernel/traps.c 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/arch/mips/kernel/traps.c 2007-09-21 16:24:11.000000000 +0800
-@@ -1075,10 +1075,23 @@
+--- linux-2.6.23.17.orig/arch/mips/kernel/traps.c
++++ linux-2.6.23.17/arch/mips/kernel/traps.c
+@@ -1075,10 +1075,23 @@ void *set_except_vector(int n, void *add
exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) {
@@ -57,11 +57,11 @@ Index: linux-2.6.23-rc6/arch/mips/kernel/traps.c
return (void *)old_handler;
}
-Index: linux-2.6.23-rc6/arch/mips/Makefile
+Index: linux-2.6.23.17/arch/mips/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/arch/mips/Makefile 2007-09-21 16:24:05.000000000 +0800
-+++ linux-2.6.23-rc6/arch/mips/Makefile 2007-09-21 16:24:11.000000000 +0800
-@@ -161,6 +161,13 @@
+--- linux-2.6.23.17.orig/arch/mips/Makefile
++++ linux-2.6.23.17/arch/mips/Makefile
+@@ -161,6 +161,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
#
#
@@ -75,11 +75,11 @@ Index: linux-2.6.23-rc6/arch/mips/Makefile
# Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
#
core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/
-Index: linux-2.6.23-rc6/include/asm-mips/page.h
+Index: linux-2.6.23.17/include/asm-mips/page.h
===================================================================
---- linux-2.6.23-rc6.orig/include/asm-mips/page.h 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/include/asm-mips/page.h 2007-09-21 16:24:11.000000000 +0800
-@@ -184,8 +184,10 @@
+--- linux-2.6.23.17.orig/include/asm-mips/page.h
++++ linux-2.6.23.17/include/asm-mips/page.h
+@@ -184,8 +184,10 @@ typedef struct { unsigned long pgprot; }
#define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)
diff --git a/target/linux/ar7/patches-2.6.23/110-flash.patch b/target/linux/ar7/patches-2.6.23/110-flash.patch
index 4f6a3c2879..fa6010814c 100644
--- a/target/linux/ar7/patches-2.6.23/110-flash.patch
+++ b/target/linux/ar7/patches-2.6.23/110-flash.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/drivers/mtd/Kconfig
+Index: linux-2.6.23.17/drivers/mtd/Kconfig
===================================================================
---- linux-2.6.23-rc6.orig/drivers/mtd/Kconfig 2007-09-21 16:23:59.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/mtd/Kconfig 2007-09-21 16:24:11.000000000 +0800
-@@ -160,6 +160,12 @@
+--- linux-2.6.23.17.orig/drivers/mtd/Kconfig
++++ linux-2.6.23.17/drivers/mtd/Kconfig
+@@ -160,6 +160,12 @@ config MTD_AFS_PARTS
for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
@@ -15,11 +15,11 @@ Index: linux-2.6.23-rc6/drivers/mtd/Kconfig
comment "User Modules And Translation Layers"
config MTD_CHAR
-Index: linux-2.6.23-rc6/drivers/mtd/Makefile
+Index: linux-2.6.23.17/drivers/mtd/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/drivers/mtd/Makefile 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/mtd/Makefile 2007-09-21 16:24:11.000000000 +0800
-@@ -11,6 +11,7 @@
+--- linux-2.6.23.17.orig/drivers/mtd/Makefile
++++ linux-2.6.23.17/drivers/mtd/Makefile
+@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
@@ -27,11 +27,11 @@ Index: linux-2.6.23-rc6/drivers/mtd/Makefile
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
-Index: linux-2.6.23-rc6/drivers/mtd/maps/physmap.c
+Index: linux-2.6.23.17/drivers/mtd/maps/physmap.c
===================================================================
---- linux-2.6.23-rc6.orig/drivers/mtd/maps/physmap.c 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/mtd/maps/physmap.c 2007-09-21 16:24:11.000000000 +0800
-@@ -74,7 +74,8 @@
+--- linux-2.6.23.17.orig/drivers/mtd/maps/physmap.c
++++ linux-2.6.23.17/drivers/mtd/maps/physmap.c
+@@ -74,7 +74,8 @@ static int physmap_flash_remove(struct p
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
diff --git a/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch b/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
index 53fd7796a1..a61f3e0dbf 100644
--- a/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
+++ b/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/drivers/char/Kconfig
+Index: linux-2.6.23.17/drivers/char/Kconfig
===================================================================
---- linux-2.6.23-rc6.orig/drivers/char/Kconfig 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/char/Kconfig 2007-09-21 16:24:12.000000000 +0800
-@@ -928,6 +928,15 @@
+--- linux-2.6.23.17.orig/drivers/char/Kconfig
++++ linux-2.6.23.17/drivers/char/Kconfig
+@@ -928,6 +928,15 @@ config MWAVE
To compile this driver as a module, choose M here: the
module will be called mwave.
@@ -18,11 +18,11 @@ Index: linux-2.6.23-rc6/drivers/char/Kconfig
config SCx200_GPIO
tristate "NatSemi SCx200 GPIO Support"
depends on SCx200
-Index: linux-2.6.23-rc6/drivers/char/Makefile
+Index: linux-2.6.23.17/drivers/char/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/drivers/char/Makefile 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/char/Makefile 2007-09-21 16:24:12.000000000 +0800
-@@ -89,6 +89,7 @@
+--- linux-2.6.23.17.orig/drivers/char/Makefile
++++ linux-2.6.23.17/drivers/char/Makefile
+@@ -89,6 +89,7 @@ obj-$(CONFIG_COBALT_LCD) += lcd.o
obj-$(CONFIG_PPDEV) += ppdev.o
obj-$(CONFIG_NWBUTTON) += nwbutton.o
obj-$(CONFIG_NWFLASH) += nwflash.o
diff --git a/target/linux/ar7/patches-2.6.23/130-vlynq.patch b/target/linux/ar7/patches-2.6.23/130-vlynq.patch
index 580b7077f4..8f7e94b344 100644
--- a/target/linux/ar7/patches-2.6.23/130-vlynq.patch
+++ b/target/linux/ar7/patches-2.6.23/130-vlynq.patch
@@ -1,17 +1,19 @@
-diff -urN linux-2.6.23.1.orig/drivers/Kconfig linux-2.6.23.1/drivers/Kconfig
---- linux-2.6.23.1.orig/drivers/Kconfig 2008-01-29 00:49:27.000000000 +0100
-+++ linux-2.6.23.1/drivers/Kconfig 2008-01-29 00:50:39.000000000 +0100
-@@ -91,4 +91,6 @@
+Index: linux-2.6.23.17/drivers/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/drivers/Kconfig
++++ linux-2.6.23.17/drivers/Kconfig
+@@ -93,4 +93,6 @@ source "drivers/kvm/Kconfig"
source "drivers/uio/Kconfig"
source "drivers/lguest/Kconfig"
+
+source "drivers/vlynq/Kconfig"
endmenu
-diff -urN linux-2.6.23.1.orig/drivers/Makefile linux-2.6.23.1/drivers/Makefile
---- linux-2.6.23.1.orig/drivers/Makefile 2008-01-29 00:49:27.000000000 +0100
-+++ linux-2.6.23.1/drivers/Makefile 2008-01-29 00:51:20.000000000 +0100
-@@ -88,4 +88,5 @@
+Index: linux-2.6.23.17/drivers/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/Makefile
++++ linux-2.6.23.17/drivers/Makefile
+@@ -89,4 +89,5 @@ obj-$(CONFIG_DMA_ENGINE) += dma/
obj-$(CONFIG_HID) += hid/
obj-$(CONFIG_PPC_PS3) += ps3/
obj-$(CONFIG_OF) += of/
diff --git a/target/linux/ar7/patches-2.6.23/140-watchdog.patch b/target/linux/ar7/patches-2.6.23/140-watchdog.patch
index 6bd9e458d0..09a8ad5b9b 100644
--- a/target/linux/ar7/patches-2.6.23/140-watchdog.patch
+++ b/target/linux/ar7/patches-2.6.23/140-watchdog.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/drivers/char/watchdog/Kconfig
+Index: linux-2.6.23.17/drivers/char/watchdog/Kconfig
===================================================================
---- linux-2.6.23-rc6.orig/drivers/char/watchdog/Kconfig 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/char/watchdog/Kconfig 2007-09-21 16:24:12.000000000 +0800
-@@ -583,6 +583,12 @@
+--- linux-2.6.23.17.orig/drivers/char/watchdog/Kconfig
++++ linux-2.6.23.17/drivers/char/watchdog/Kconfig
+@@ -583,6 +583,12 @@ config SBC_EPX_C3_WATCHDOG
# MIPS Architecture
@@ -15,11 +15,11 @@ Index: linux-2.6.23-rc6/drivers/char/watchdog/Kconfig
config INDYDOG
tristate "Indy/I2 Hardware Watchdog"
depends on SGI_IP22
-Index: linux-2.6.23-rc6/drivers/char/watchdog/Makefile
+Index: linux-2.6.23.17/drivers/char/watchdog/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/drivers/char/watchdog/Makefile 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/char/watchdog/Makefile 2007-09-21 16:24:12.000000000 +0800
-@@ -87,6 +87,7 @@
+--- linux-2.6.23.17.orig/drivers/char/watchdog/Makefile
++++ linux-2.6.23.17/drivers/char/watchdog/Makefile
+@@ -87,6 +87,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
# M68KNOMMU Architecture
# MIPS Architecture
diff --git a/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch b/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch
index 08f26576be..0f13204a76 100644
--- a/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch
+++ b/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23/drivers/net/Kconfig
+Index: linux-2.6.23.17/drivers/net/Kconfig
===================================================================
---- linux-2.6.23.orig/drivers/net/Kconfig 2007-10-10 13:52:54.000000000 +0800
-+++ linux-2.6.23/drivers/net/Kconfig 2007-10-10 13:53:54.000000000 +0800
-@@ -1965,6 +1965,15 @@
+--- linux-2.6.23.17.orig/drivers/net/Kconfig
++++ linux-2.6.23.17/drivers/net/Kconfig
+@@ -1965,6 +1965,15 @@ config SC92031
To compile this driver as a module, choose M here: the module
will be called sc92031. This is recommended.
@@ -18,11 +18,11 @@ Index: linux-2.6.23/drivers/net/Kconfig
config NET_POCKET
bool "Pocket and portable adapters"
depends on PARPORT
-Index: linux-2.6.23/drivers/net/Makefile
+Index: linux-2.6.23.17/drivers/net/Makefile
===================================================================
---- linux-2.6.23.orig/drivers/net/Makefile 2007-10-10 13:52:54.000000000 +0800
-+++ linux-2.6.23/drivers/net/Makefile 2007-10-10 13:53:54.000000000 +0800
-@@ -156,6 +156,7 @@
+--- linux-2.6.23.17.orig/drivers/net/Makefile
++++ linux-2.6.23.17/drivers/net/Makefile
+@@ -156,6 +156,7 @@ obj-$(CONFIG_8139CP) += 8139cp.o
obj-$(CONFIG_8139TOO) += 8139too.o
obj-$(CONFIG_ZNET) += znet.o
obj-$(CONFIG_LAN_SAA9730) += saa9730.o
diff --git a/target/linux/ar7/patches-2.6.23/210-phy_fixed.patch b/target/linux/ar7/patches-2.6.23/210-phy_fixed.patch
index de49ff9d3f..24040786c0 100644
--- a/target/linux/ar7/patches-2.6.23/210-phy_fixed.patch
+++ b/target/linux/ar7/patches-2.6.23/210-phy_fixed.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/drivers/net/phy/fixed.c
+Index: linux-2.6.23.17/drivers/net/phy/fixed.c
===================================================================
---- linux-2.6.23-rc6.orig/drivers/net/phy/fixed.c 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/net/phy/fixed.c 2007-09-21 16:24:13.000000000 +0800
-@@ -189,6 +189,19 @@
+--- linux-2.6.23.17.orig/drivers/net/phy/fixed.c
++++ linux-2.6.23.17/drivers/net/phy/fixed.c
+@@ -189,6 +189,19 @@ static struct phy_driver fixed_mdio_driv
.driver = { .owner = THIS_MODULE,},
};
@@ -22,7 +22,7 @@ Index: linux-2.6.23-rc6/drivers/net/phy/fixed.c
/*-----------------------------------------------------------------------------
* This func is used to create all the necessary stuff, bind
* the fixed phy driver and register all it on the mdio_bus_type.
-@@ -224,6 +237,12 @@
+@@ -224,6 +237,12 @@ static int fixed_mdio_register_device(in
}
fixed->regs = kzalloc(MII_REGS_NUM*sizeof(int), GFP_KERNEL);
@@ -35,7 +35,7 @@ Index: linux-2.6.23-rc6/drivers/net/phy/fixed.c
fixed->regs_num = MII_REGS_NUM;
fixed->phy_status.speed = speed;
fixed->phy_status.duplex = duplex;
-@@ -252,8 +271,11 @@
+@@ -252,8 +271,11 @@ static int fixed_mdio_register_device(in
fixed->phydev = phydev;
if(NULL == phydev) {
@@ -49,7 +49,7 @@ Index: linux-2.6.23-rc6/drivers/net/phy/fixed.c
}
phydev->irq = PHY_IGNORE_INTERRUPT;
-@@ -265,8 +287,33 @@
+@@ -265,8 +287,33 @@ static int fixed_mdio_register_device(in
else
snprintf(phydev->dev.bus_id, BUS_ID_SIZE,
"fixed@%d:%d", speed, duplex);
@@ -83,7 +83,7 @@ Index: linux-2.6.23-rc6/drivers/net/phy/fixed.c
err = device_register(&phydev->dev);
if(err) {
printk(KERN_ERR "Phy %s failed to register\n",
-@@ -303,6 +350,7 @@
+@@ -303,6 +350,7 @@ device_create_fail:
kfree(fixed);
return err;
diff --git a/target/linux/ar7/patches-2.6.23/500-serial_kludge.patch b/target/linux/ar7/patches-2.6.23/500-serial_kludge.patch
index 446b2b555c..f695d2a8e4 100644
--- a/target/linux/ar7/patches-2.6.23/500-serial_kludge.patch
+++ b/target/linux/ar7/patches-2.6.23/500-serial_kludge.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/drivers/serial/8250.c
+Index: linux-2.6.23.17/drivers/serial/8250.c
===================================================================
---- linux-2.6.23-rc6.orig/drivers/serial/8250.c 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/serial/8250.c 2007-09-21 16:24:14.000000000 +0800
-@@ -267,6 +267,13 @@
+--- linux-2.6.23.17.orig/drivers/serial/8250.c
++++ linux-2.6.23.17/drivers/serial/8250.c
+@@ -267,6 +267,13 @@ static const struct serial8250_config ua
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO,
},
@@ -16,7 +16,7 @@ Index: linux-2.6.23-rc6/drivers/serial/8250.c
};
#if defined (CONFIG_SERIAL_8250_AU1X00)
-@@ -2453,7 +2460,11 @@
+@@ -2455,7 +2462,11 @@ static void serial8250_console_putchar(s
{
struct uart_8250_port *up = (struct uart_8250_port *)port;
@@ -28,10 +28,10 @@ Index: linux-2.6.23-rc6/drivers/serial/8250.c
serial_out(up, UART_TX, ch);
}
-Index: linux-2.6.23-rc6/include/linux/serial_core.h
+Index: linux-2.6.23.17/include/linux/serial_core.h
===================================================================
---- linux-2.6.23-rc6.orig/include/linux/serial_core.h 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/include/linux/serial_core.h 2007-09-21 16:24:14.000000000 +0800
+--- linux-2.6.23.17.orig/include/linux/serial_core.h
++++ linux-2.6.23.17/include/linux/serial_core.h
@@ -40,6 +40,7 @@
#define PORT_NS16550A 14
#define PORT_XSCALE 15
@@ -40,11 +40,11 @@ Index: linux-2.6.23-rc6/include/linux/serial_core.h
#define PORT_MAX_8250 16 /* max port ID */
/*
-Index: linux-2.6.23-rc6/include/linux/serialP.h
+Index: linux-2.6.23.17/include/linux/serialP.h
===================================================================
---- linux-2.6.23-rc6.orig/include/linux/serialP.h 2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/include/linux/serialP.h 2007-09-21 16:24:14.000000000 +0800
-@@ -135,6 +135,10 @@
+--- linux-2.6.23.17.orig/include/linux/serialP.h
++++ linux-2.6.23.17/include/linux/serialP.h
+@@ -135,6 +135,10 @@ struct rs_multiport_struct {
* the interrupt line _up_ instead of down, so if we register the IRQ
* while the UART is in that state, we die in an IRQ storm. */
#define ALPHA_KLUDGE_MCR (UART_MCR_OUT2)