summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorEugene Konev <ejka@imfi.kspu.ru>2007-10-04 02:27:37 +0000
committerEugene Konev <ejka@imfi.kspu.ru>2007-10-04 02:27:37 +0000
commit3120f8a5c0c7be00ee96ba9117b58f9def394d75 (patch)
tree70a65bdb9caae91b6a862b5248afb9b066e8b364 /target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
parent6efb8c8df8cd8ccef6866e5c1f5e8b008b1c1c3f (diff)
downloadmaster-31e0f0ae-3120f8a5c0c7be00ee96ba9117b58f9def394d75.tar.gz
master-31e0f0ae-3120f8a5c0c7be00ee96ba9117b58f9def394d75.tar.bz2
master-31e0f0ae-3120f8a5c0c7be00ee96ba9117b58f9def394d75.zip
add ar7 2.6.23 patches and config
SVN-Revision: 9115
Diffstat (limited to 'target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch b/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..53fd7796a1
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.23/120-gpio_chrdev.patch
@@ -0,0 +1,32 @@
+Index: linux-2.6.23-rc6/drivers/char/Kconfig
+===================================================================
+--- linux-2.6.23-rc6.orig/drivers/char/Kconfig 2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/drivers/char/Kconfig 2007-09-21 16:24:12.000000000 +0800
+@@ -928,6 +928,15 @@
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+Index: linux-2.6.23-rc6/drivers/char/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/drivers/char/Makefile 2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/drivers/char/Makefile 2007-09-21 16:24:12.000000000 +0800
+@@ -89,6 +89,7 @@
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o