summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:36 +0000
commite85a44f11ba3d975789e1b8c8032b7d5197052c0 (patch)
tree6e063845f812a217c3d27b0cce556048a05de47f /target/linux/ar7/image
parent71dc2715a9d73b5f0e7797bfe942fedd09f2427e (diff)
downloadmaster-31e0f0ae-e85a44f11ba3d975789e1b8c8032b7d5197052c0.tar.gz
master-31e0f0ae-e85a44f11ba3d975789e1b8c8032b7d5197052c0.tar.bz2
master-31e0f0ae-e85a44f11ba3d975789e1b8c8032b7d5197052c0.zip
ar7: fix kernel_entry extraction
SVN-Revision: 31614
Diffstat (limited to 'target/linux/ar7/image')
-rw-r--r--target/linux/ar7/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar7/image/Makefile b/target/linux/ar7/image/Makefile
index 2d8ef64271..d27c2e8888 100644
--- a/target/linux/ar7/image/Makefile
+++ b/target/linux/ar7/image/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -75,9 +75,9 @@ endef
#endef
define Image/Build/EVA
- $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep -w kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva
dd if=$(KDIR)/loader.eva $(call align/$(1)) > $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
- cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
$(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
endef