summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-06 19:35:08 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-06 19:35:08 +0000
commit929f86c30eb030b6eb52c44326a1b4d4a57aa2c6 (patch)
treecf8bcaa2e3863b6ab2935275f76d8db545eaca2f /target/linux/ar7/image
parent22742b2d7e46c5cf1a0e2e5ce4963640d0181f15 (diff)
downloadmaster-31e0f0ae-929f86c30eb030b6eb52c44326a1b4d4a57aa2c6.tar.gz
master-31e0f0ae-929f86c30eb030b6eb52c44326a1b4d4a57aa2c6.tar.bz2
master-31e0f0ae-929f86c30eb030b6eb52c44326a1b4d4a57aa2c6.zip
cosmetic fixes for ar7: indent, use lowercase hex notation, format
SVN-Revision: 8656
Diffstat (limited to 'target/linux/ar7/image')
-rw-r--r--target/linux/ar7/image/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/target/linux/ar7/image/Makefile b/target/linux/ar7/image/Makefile
index 27af165533..b80af35408 100644
--- a/target/linux/ar7/image/Makefile
+++ b/target/linux/ar7/image/Makefile
@@ -7,20 +7,22 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
-OBJCOPY_SREC := $(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
+DROP_SECTIONS:=.reginfo .mdebug .comment .note .pdr .options .MIPS.options
+OBJCOPY_SREC:=$(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
-LOADADDR := 0x94600000
-KERNEL_ENTRY := 0x94100000
-RAMSTART := 0x94000000
-RAMSIZE := 0x00100000
+LOADADDR:=0x94600000
+KERNEL_ENTRY:=0x94100000
+RAMSTART:=0x94000000
+RAMSIZE:=0x00100000
+
+EVA_LOADADDR := 0x94100000
LOADER_MAKEOPTS= \
- KDIR=$(KDIR) \
- LOADADDR=$(LOADADDR) \
- KERNEL_ENTRY=$(KERNEL_ENTRY) \
- RAMSTART=$(RAMSTART) \
- RAMSIZE=$(RAMSIZE)
+ KDIR=$(KDIR) \
+ LOADADDR=$(LOADADDR) \
+ KERNEL_ENTRY=$(KERNEL_ENTRY) \
+ RAMSTART=$(RAMSTART) \
+ RAMSIZE=$(RAMSIZE)
CFLAGS := -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \