summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
commit1bca0cc51704b5ef57c5e3a9d7a1b80633486d16 (patch)
tree44d959af03ba5f4cf55929b6d930439b6335d0c4 /target/linux/ar7/image
parentf8d965201b053be42f7690a75fd0a529608c5af3 (diff)
downloadmaster-31e0f0ae-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.tar.gz
master-31e0f0ae-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.tar.bz2
master-31e0f0ae-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.zip
make the image filenames a bit shorter
SVN-Revision: 9533
Diffstat (limited to 'target/linux/ar7/image')
-rw-r--r--target/linux/ar7/image/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/ar7/image/Makefile b/target/linux/ar7/image/Makefile
index 8947f2fd99..8952b09cec 100644
--- a/target/linux/ar7/image/Makefile
+++ b/target/linux/ar7/image/Makefile
@@ -53,27 +53,27 @@ bs=131072 conv=sync
endef
define Image/Build/CyberTAN
- (dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin) | \
- $(STAGING_DIR_HOST)/bin/addpattern -p $(3) -o $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(4).bin
+ (dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin) | \
+ $(STAGING_DIR_HOST)/bin/addpattern -p $(3) -o $(BIN_DIR)/openwrt-$(2)-$(4).bin
endef
#define Image/Build/sErCoMm
-# cat sercomm/adam2.bin "$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin" > "$(KDIR)/dgfw.tmp"
+# cat sercomm/adam2.bin "$(BIN_DIR)/openwrt-$(BOARD)-$(1).bin" > "$(KDIR)/dgfw.tmp"
# dd if=sercomm/$(2) of="$(KDIR)/dgfw.tmp" bs=$$$$((0x3e0000 - 80)) seek=1 conv=notrunc
-# $(STAGING_DIR_HOST)/bin/dgfirmware -f -w "$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(3).img" "$(KDIR)/dgfw.tmp"
+# $(STAGING_DIR_HOST)/bin/dgfirmware -f -w "$(BIN_DIR)/openwrt-$(2)-$(3).img" "$(KDIR)/dgfw.tmp"
# rm -f "$(KDIR)/dgfw.tmp"
#endef
define Image/Build/EVA
- $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_ENTRY) $(KERNEL_ENTRY) $(KDIR)/vmlinux.lzma $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
- cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
- $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_ENTRY) $(KERNEL_ENTRY) $(KDIR)/vmlinux.lzma $(BIN_DIR)/openwrt-$(2)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(1).bin
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1).bin)
endef
define Image/Build
- dd if=$(KDIR)/loader.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
- cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
- $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin)
+ dd if=$(KDIR)/loader.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(1).bin)
$(call Image/Build/CyberTAN,$(1),AG1B,AG1B,$(1))
$(call Image/Build/CyberTAN,$(1),WA21,WA21,$(1))
$(call Image/Build/CyberTAN,$(1),WA22,WA22,$(1))