summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7-2.4/base-files.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-22 23:27:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-22 23:27:29 +0000
commit37362df7ea5978750f4584d2ce48623c59ef0695 (patch)
tree8f8734b13f1e320ab42aed2a46bb22472a61c479 /target/linux/ar7-2.4/base-files.mk
parentbd8e5fb7db8431d22fad5eb72a2a38c0f1b50f45 (diff)
downloadmaster-31e0f0ae-37362df7ea5978750f4584d2ce48623c59ef0695.tar.gz
master-31e0f0ae-37362df7ea5978750f4584d2ce48623c59ef0695.tar.bz2
master-31e0f0ae-37362df7ea5978750f4584d2ce48623c59ef0695.zip
move platform specific base-files into target/linux/<targetname>
SVN-Revision: 5621
Diffstat (limited to 'target/linux/ar7-2.4/base-files.mk')
-rw-r--r--target/linux/ar7-2.4/base-files.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar7-2.4/base-files.mk b/target/linux/ar7-2.4/base-files.mk
new file mode 100644
index 0000000000..f21a604b83
--- /dev/null
+++ b/target/linux/ar7-2.4/base-files.mk
@@ -0,0 +1,11 @@
+define Build/Compile
+ $(call Build/Compile/Default)
+ $(TARGET_CC) -o $(PKG_BUILD_DIR)/adam2patcher $(PLATFORM_DIR)/src/adam2patcher.c
+endef
+
+define Package/base-files/install-target
+ mkdir -p $(1)/sbin
+ $(CP) $(PKG_BUILD_DIR)/adam2patcher $(1)/sbin
+endef
+
+