summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorriptidewave93 <chrisrblake93@gmail.com>2016-09-02 06:17:24 -0500
committerJohn Crispin <john@phrozen.org>2016-09-05 07:28:44 +0200
commitbc36678bdb0223774cf0d088b80b2f0c1e6737db (patch)
tree9cdaf346a5eba9ed9a4da7c626b40c64e02e1177 /target/linux/apm821xx
parenta4dc9ff934ce8ed11b6517deb0b93ae0fd6da93f (diff)
downloadmaster-31e0f0ae-bc36678bdb0223774cf0d088b80b2f0c1e6737db.tar.gz
master-31e0f0ae-bc36678bdb0223774cf0d088b80b2f0c1e6737db.tar.bz2
master-31e0f0ae-bc36678bdb0223774cf0d088b80b2f0c1e6737db.zip
apm821xx: Fix initramfs image for the Meraki MR24
When gzip is used, our kernel is too large and this causes the ramdisk to be at the wrong offset. Fix by moving to lzma. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 100db560d4..8edd5780f0 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -75,7 +75,7 @@ define Device/mr24
KERNEL_SIZE := 2048k
IMAGE_SIZE := 8191k
KERNEL := kernel-bin | lzma | uImage lzma | MerakiAdd-dtb | MerakiNAND
- KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux | gzip | uImage gzip | MerakiAdd-dtb | pad-to 2047k | MerakiAdd-initramfs | MerakiNAND
+ KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux | lzma | uImage lzma | MerakiAdd-dtb | pad-to 2047k | MerakiAdd-initramfs | MerakiNAND
IMAGE/sysupgrade.tar := sysupgrade-tar
endef
TARGET_DEVICES += mr24