summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-30 14:19:11 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 12:25:25 +0200
commit63b525dd6b209af5554a2d053efd4b3ce6f60c9c (patch)
treeb4bf688fa7ce3b9cbbad996dd0d60730eacbede9 /target/linux/apm821xx
parent9201e88f518dbe5246aa2f77342175805ef10cdd (diff)
downloadmaster-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.gz
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.bz2
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.zip
image: add a helper variable for getting kernel/rootfs from within image Build/* templates
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index c49e57abc4..25ee67b673 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -179,7 +179,7 @@ define Build/boot-img
$(CP) $@.scr $@.bootdir/boot/boot.scr
$(CP) $@.dtb $@.bootdir/boot/$(DEVICE_DTB)
- $(CP) $(word 1,$^) $@.bootdir/boot/uImage
+ $(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
genext2fs --block-size $(BLOCKSIZE) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
@@ -189,7 +189,7 @@ define Build/boot-img
endef
define Build/hdd-img
- ./mbl_gen_hdd_img.sh $@ $@.boot $(word 2,$^)
+ ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS)
$(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
@@ -204,9 +204,9 @@ endef
define Build/recovery-tar
sh ./mbl_gen_recovery_tar.sh \
--profile $(DEVICE_PROFILE) \
- --dtb $(word 1,$^).dtb \
+ --dtb $(IMAGE_KERNEL).dtb \
--dtbname $(DEVICE_DTB) \
- --kernel $(word 1,$^) \
+ --kernel $(IMAGE_KERNEL) \
--rootfs $@ \
$@
endef