summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-21 15:09:55 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commit44c39d581254862c63ba0dfaad1ddd99eaec968a (patch)
treedca2c4ab21df6e42da4b39322f7ce94fe22ea232 /target/linux/apm821xx
parent9e0fd1b52ad1f805a308bf6a5a13236f352fd962 (diff)
downloadmaster-31e0f0ae-44c39d581254862c63ba0dfaad1ddd99eaec968a.tar.gz
master-31e0f0ae-44c39d581254862c63ba0dfaad1ddd99eaec968a.tar.bz2
master-31e0f0ae-44c39d581254862c63ba0dfaad1ddd99eaec968a.zip
apm821xx: add missing default profiles for subtargets
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/Makefile1
-rw-r--r--target/linux/apm821xx/nand/profiles/00-default.mk22
-rw-r--r--target/linux/apm821xx/sata/profiles/00-default.mk18
3 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 08173c603f..649c501014 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -9,6 +9,7 @@ include $(INCLUDE_DIR)/host.mk
DEVICE_VARS += DEVICE_DTS DEVICE_PROFILE IMAGE_SIZE DTB_SIZE
define Device/Default
+ PROFILES := Default
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
DEVICE_PROFILE :=
DEVICE_DTS :=
diff --git a/target/linux/apm821xx/nand/profiles/00-default.mk b/target/linux/apm821xx/nand/profiles/00-default.mk
new file mode 100644
index 0000000000..9b3e84feaf
--- /dev/null
+++ b/target/linux/apm821xx/nand/profiles/00-default.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+ PACKAGES := badblocks block-mount e2fsprogs \
+ kmod-ath9k kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-ledtrig-usbdev \
+ kmod-md-mod kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
+ kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
+ kmod-spi-gpio partx-utils swconfig wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set
+endef
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/apm821xx/sata/profiles/00-default.mk b/target/linux/apm821xx/sata/profiles/00-default.mk
new file mode 100644
index 0000000000..7446a080bd
--- /dev/null
+++ b/target/linux/apm821xx/sata/profiles/00-default.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+ PACKAGES := kmod-usb-dwc2 kmod-ledtrig-usbdev kmod-usb-storage kmod-fs-vfat wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set
+endef
+
+$(eval $(call Profile,Default))