summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-07-23 14:20:52 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-25 10:38:11 +0200
commit08257a40530df36528fb2916fe8cf4ecddc526eb (patch)
tree9b3f5baa2080a92316114aee88bee96ec7d9e8b0 /target/linux/apm821xx
parent04a69843198f2252992812e35ac05016db4a1a94 (diff)
downloadmaster-31e0f0ae-08257a40530df36528fb2916fe8cf4ecddc526eb.tar.gz
master-31e0f0ae-08257a40530df36528fb2916fe8cf4ecddc526eb.tar.bz2
master-31e0f0ae-08257a40530df36528fb2916fe8cf4ecddc526eb.zip
apm821xx: use lzma compression for the initramfs images
The MR24's u-boot takes it sweet time decompressing the LZMA-packed initramfs image. A user reported that compared to the old gzip method in v2: it "takes a ton longer to decompress like 4\x the old boot time for decompression". This patch also fixes a issue with the WNDR4700's initramfs image getting to big and causing the following u-boot crash during the decompression: "Uncompressing Multi-File Image ... Error: inflate() returned -5 out-of-mem or overwrite error - must RESET board to recover" This patch fixes both issues by reverting the MR24's initramfs compression method back to gzip. And choosing to compress the initramfs within the initramfs image as LZMA by default. Cc: chrisrblake93@gmail.com Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index bee0e1c8d5..6ad4d99c11 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -75,7 +75,7 @@ define Device/mr24
KERNEL_SIZE := 2048k
IMAGE_SIZE := 8191k
KERNEL := kernel-bin | lzma | uImage lzma | MerakiAdd-dtb | MerakiNAND
- KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux | lzma | uImage lzma | MerakiAdd-dtb | pad-to 2047k | MerakiAdd-initramfs | MerakiNAND
+ KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux | gzip | uImage gzip | MerakiAdd-dtb | pad-to 2047k | MerakiAdd-initramfs | MerakiNAND
IMAGE/sysupgrade.tar := sysupgrade-nand
endef
TARGET_DEVICES += mr24