summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/nand
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2016-07-20 15:44:51 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commita57d6e2d47688cfa392d6ea7f36ae6f9d84affc5 (patch)
treed2e04f9253dd23c513a662eed52c37ee959b5729 /target/linux/apm821xx/nand
parent3827ce2c3dc1849033d6de52e58fcbccc7ed74a2 (diff)
downloadmaster-31e0f0ae-a57d6e2d47688cfa392d6ea7f36ae6f9d84affc5.tar.gz
master-31e0f0ae-a57d6e2d47688cfa392d6ea7f36ae6f9d84affc5.tar.bz2
master-31e0f0ae-a57d6e2d47688cfa392d6ea7f36ae6f9d84affc5.zip
apm821xx: add support for the Cisco Meraki MR24
This patch adds support for the Cisco Meraki MR24 Access point to the apm821xx target. Board: MR24 - Meraki MR24 Cloud Managed Access Point CPU: APM82181 SoC 800 MHz (PLB=200 OPB=100 EBC=100) Flash size: 32MiB RAM Size: 128MiB Wireless: Atheros AR9380 5.0GHz + Atheros AR9380 2.4GHz Ethernet ports: 1x Gigabit Atheros AR8035 WARNING: The serial port needs a TTL/RS-232 v3.3 level converter! For flashing instructions, visit: <https://github.com/riptidewave93/Openwrt-MR24/blob/master/README.md#flashing> Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/nand')
-rw-r--r--target/linux/apm821xx/nand/config-default9
-rw-r--r--target/linux/apm821xx/nand/target.mk7
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/apm821xx/nand/config-default b/target/linux/apm821xx/nand/config-default
new file mode 100644
index 0000000000..582d1295bc
--- /dev/null
+++ b/target/linux/apm821xx/nand/config-default
@@ -0,0 +1,9 @@
+CONFIG_IKAREM=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+CONFIG_MTD_UBI_BLOCK=y
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_UBIFS_FS=y
+# CONFIG_UBIFS_FS_ADVANCED_COMPR is not set
diff --git a/target/linux/apm821xx/nand/target.mk b/target/linux/apm821xx/nand/target.mk
new file mode 100644
index 0000000000..a7d88b87c5
--- /dev/null
+++ b/target/linux/apm821xx/nand/target.mk
@@ -0,0 +1,7 @@
+BOARDNAME:=Devices with NAND flash (Routers)
+FEATURES += nand pcie ramdisk squashfs usb
+
+define Target/Description
+ Build firmware images for APM821XX boards with NAND flash.
+ For routers like the MR24 or the WNDR4700.
+endef