summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-07-20 15:44:57 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commit9e0fd1b52ad1f805a308bf6a5a13236f352fd962 (patch)
treec01eaf08bb04ea37b07070469e8077c402a5d111 /target/linux/apm821xx/image
parent47eeb9f857044de6e79c79577a1a7d6a57ac5046 (diff)
downloadmaster-31e0f0ae-9e0fd1b52ad1f805a308bf6a5a13236f352fd962.tar.gz
master-31e0f0ae-9e0fd1b52ad1f805a308bf6a5a13236f352fd962.tar.bz2
master-31e0f0ae-9e0fd1b52ad1f805a308bf6a5a13236f352fd962.zip
apm821xx: add support for the Netgear Centria N900 WNDR4700/WNDR4720
This patch adds support for Netgear Centria N900 WNDR4700/WNDR4720 hardware highlights: CPU: AMCC PowerPC APM82181 Rev. E at 1000 MHz (PLB=166, OPB=83, EBC=83 MHz) Security support, Boot ROM Location NAND wo/ECC 2k page (8 bits) 32 kB I-Cache 32 kB D-Cache, 256 kB L2-Cache, 32 kB OnChip Memory Board: AMCC APM82181 Evaluation Board, PCIE0/SATA1, 1*USB OTG DRAM: 256 MB (ECC not enabled, 500 Mb/s, 32-bit, CL3) NAND: 128 MiB (SLC, erase size: 128 KiB, page size: 2048, OOB size: 64) ETH: Atheros AR8327N Gigabit Switch (4 x LAN, 1 x WAN) USB: 2 x 3.0 (Renesas uPD720202K8-711-BAA-A, firmware not included) SATA: 1 x SATA-II 3.5" Hard Drive Bay for HDDs (DesignWare SATA). WLAN1: Atheros AR9380 5GHz 802.11an 3:3x3 WLAN2: Atheros AR9581 2.4GHz 802.11bgn 3:3x3 SDCARD: GL827L SD/MMC/MS Flash Card Reader (on internal dwc2 USB 2.0 host) I2C: GMT G781 (i2c-0 @ 0x4d - lm90 compatible temperature sensor) TC654 (i2c-0 @ 0x1b - Dual PWM fan Speed controller) WARNING: The serial port needs a TTL/RS-232 v3.3 level converter! INFO: Since this device only has a NAND chip. I opted for going with root.squashfs in a UBI volume. There's no squashfs/jffs2 image. This target produces three images. a. netgear factory image This image can be used to flash the Netgear WNDR4700 via the firmware recovery mechanism and the web admin site. The bootloader can be instructed to do a firmware recovery via the # fw_recovery command. It will start a tftp server and listen on 192.168.1.1 (the ipaddr variable in u-boot) for incoming, binary tftp clients. The firmware recovery mechanism is also started if any of the flash content which contains the kernel, device-tree definitions or the (fake)rootfs fails to verify or load. b. sysupgrade.tar image for sysupgrade An sysupgrade will replace the entire current LEDE installation with a newer version. This does include the kernel and the ubi rootfs partition. The configuration can be carried over automatically as well if desired. simply copy the sysupgrade.tar to a the WNDR4700 running LEDE and run: root@lede:~# sysupgrade sysupgrade.tar and let it reboot. Note: The devicetree flash area is NOT updated. Until the devicetree definition is stable, this can lead to all sorts of hardware detection problems! So make sure, if you experience issues: try the fw_recovery. If you are unsure whenever this affects you: test if you can reproduce your issue with the initramfs method. As it will always have up-to-date device-tree definitions. c. initramfs image for TFTP (for development and testing) To use the initramfs method, follow the following steps: 1) Move the "lede-apm821xx-netgear-WNDR4700-initramfs-kernel.bin" file to to the root directory of your TFTP server. 2) rename it to wndr4700.bin 3) On the WNDR4700 - Hit Enter during u-boot and insert: # tftp 400000 wndr4700.bin; run addtty; bootm 400000 - This will boot the LEDE image. Note: The default tftp server is 192.168.1.7, if you want to change it: # setenv serverip 192.168.8.7; Note2: The default address for the WNDR4700 is 192.168.1.1: # setenv ipaddr 192.168.8.8; Note: Connect you tftp server on the last LAN port (not the WAN) Note: The firmware for the USB 3.0 Host chip is not included anymore. Therefore the two USB 3.0 ports will not work without the uPD7070x-firmware package installed. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image')
-rw-r--r--target/linux/apm821xx/image/Makefile83
1 files changed, 82 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 9ba43d9db2..08173c603f 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -78,6 +78,88 @@ define Device/mr24
endef
TARGET_DEVICES += mr24
+define Build/create-uImage-dtb
+ # flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
+ -$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel -C none \
+ -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' \
+ -d $@.dtb $@.new
+ @mv $@.new $@
+endef
+
+define Build/append-fakerootfs
+ rm -rf $@.fakerootsquashfs $@.fakefs
+
+ # append a fake/empty rootfs to fool netgear's uboot
+ # CHECK_DNI_FIRMWARE_ROOTFS_INTEGRITY in do_chk_dniimg()
+ dd if=/dev/zero of=$@.fakerd bs=16 count=1 conv=sync
+
+ -$(STAGING_DIR_HOST)/bin/mkimage \
+ -A $(LINUX_KARCH) -O linux -T filesystem -C none \
+ -a 0x00000000 -e 0x00000000 \
+ -n '$(DEVICE_PROFILE) fakerootfs' \
+ -d $@.fakerd $@.fakefs
+
+ cat $@.fakefs >> $@
+ rm -rf $@.fakerootsquashfs $@.fakefs
+endef
+
+define Build/wndr4700-specialImage
+ rm -rf $@.fakerd $@.new
+
+ dd if=/dev/zero of=$@.fakerd bs=32 count=1 conv=sync
+
+ # Netgear used an old uboot that doesn't have FIT support.
+ # So we are stuck with either a full ext2/4 fs in a initrd.
+ # ... or we try to make the "multi" image approach to work
+ # for us.
+ #
+ # Sadly, the "multi" image has to consists of three
+ # "fixed" parts in the following "fixed" order:
+ # 1. The kernel which is in $@
+ # 2. The (fake) initrd which is in $@.fakerd
+ # 3. The device tree binary which is in $@.dtb
+ #
+ # Now, given that we use the function for the kernel which
+ # already has a initramfs image inside, we still have to
+ # add a "fake" initrd (which a mkimage header) in the second
+ # part of the legacy multi image. Since we need to put the
+ # device tree stuff into part 3.
+
+ -$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) -O linux -T multi \
+ -C $(1) -a $(KERNEL_LOADADDR) -e $(KERNEL_ENTRY) \
+ -n '$(DEVICE_PROFILE) initramfs' -d $@:$@.fakerd:$@.dtb $@.new
+ mv $@.new $@
+ rm -rf $@.fakerd
+endef
+
+define Device/WNDR4700
+ DEVICE_TITLE := Netgear Centria N900 WNDR4700/WNDR4720
+ DEVICE_PACKAGES := badblocks block-mount e2fsprogs \
+ kmod-ath9k kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-ledtrig-usbdev \
+ kmod-md-mod kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
+ kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
+ partx-utils swconfig wpad-mini
+ DEVICE_NAME := wndr4700
+ DEVICE_PROFILE := wndr4700
+ DEVICE_DTS := wndr4700
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ BLOCKSIZE := 131072
+ DTB_SIZE := 131008
+ IMAGE_SIZE:=25559040
+ IMAGES := factory.img sysupgrade.tar
+ KERNEL_SIZE := 1920k
+ KERNEL := kernel-bin | lzma | uImage lzma | pad-offset $$(BLOCKSIZE) 64 | append-fakerootfs
+ KERNEL_INITRAMFS := kernel-bin | gzip | dtb | wndr4700-specialImage gzip
+ IMAGE/factory.img := dtb | create-uImage-dtb | append-kernel | pad-to 2M | append-ubi | \
+ netgear-dni | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.tar := sysupgrade-nand
+ NETGEAR_BOARD_ID := WNDR4700
+ NETGEAR_HW_ID := 29763875+128+256
+endef
+TARGET_DEVICES += WNDR4700
+
endif
ifeq ($(SUBTARGET),sata)
@@ -161,4 +243,3 @@ TARGET_DEVICES += MyBookLiveDuo
endif
$(eval $(call BuildImage))
-