summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2016-07-20 15:44:50 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commit3827ce2c3dc1849033d6de52e58fcbccc7ed74a2 (patch)
tree19d5d67bd8357f47fce8c318143fdc7d65e59bb6 /target/linux/apm821xx/image
parent39f3408732df53e8671426c207f178ae0cf42d01 (diff)
downloadmaster-31e0f0ae-3827ce2c3dc1849033d6de52e58fcbccc7ed74a2.tar.gz
master-31e0f0ae-3827ce2c3dc1849033d6de52e58fcbccc7ed74a2.tar.bz2
master-31e0f0ae-3827ce2c3dc1849033d6de52e58fcbccc7ed74a2.zip
apm821xx: add support for the apm821xx device target
This adds a new target for PowerPC APM82181 and APM82161 (464-based) boards, as well as adds support for the booke-wdt watchdog package. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image')
-rw-r--r--target/linux/apm821xx/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
new file mode 100644
index 0000000000..48ada70d3f
--- /dev/null
+++ b/target/linux/apm821xx/image/Makefile
@@ -0,0 +1,22 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+IMAGE_PROFILE:=$(if $(PROFILE),$(PROFILE),Default)
+
+DEVICE_VARS += DTS IMAGE_SIZE
+
+define Device/Default
+ BOARDNAME :=
+ DEVICE_PROFILE = $$(BOARDNAME)
+ PROFILES = Default $$(DEVICE_PROFILE)
+ KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
+ KERNEL := kernel-bin | lzma | uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | lzma | uImage lzma
+endef
+TARGET_DEVICES += Default
+
+$(eval $(call BuildImage))