summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/Makefile
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2016-07-20 15:44:50 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commit3827ce2c3dc1849033d6de52e58fcbccc7ed74a2 (patch)
tree19d5d67bd8357f47fce8c318143fdc7d65e59bb6 /target/linux/apm821xx/Makefile
parent39f3408732df53e8671426c207f178ae0cf42d01 (diff)
downloadmaster-31e0f0ae-3827ce2c3dc1849033d6de52e58fcbccc7ed74a2.tar.gz
master-31e0f0ae-3827ce2c3dc1849033d6de52e58fcbccc7ed74a2.tar.bz2
master-31e0f0ae-3827ce2c3dc1849033d6de52e58fcbccc7ed74a2.zip
apm821xx: add support for the apm821xx device target
This adds a new target for PowerPC APM82181 and APM82161 (464-based) boards, as well as adds support for the booke-wdt watchdog package. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/Makefile')
-rw-r--r--target/linux/apm821xx/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/apm821xx/Makefile b/target/linux/apm821xx/Makefile
new file mode 100644
index 0000000000..5c530d3ca6
--- /dev/null
+++ b/target/linux/apm821xx/Makefile
@@ -0,0 +1,28 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=apm821xx
+BOARDNAME:=AppliedMicro APM821xx
+CPU_TYPE:=464fp
+FEATURES:=fpu dt gpio
+MAINTAINER:=Chris Blake <chrisrblake93@gmail.com>, \
+ Christian Lamparter <chunkeey@gmail.com>
+
+KERNEL_PATCHVER:=4.4
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage
+
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
+
+define Target/Description
+ Build images for AppliedMicro APM821xx based boards.
+endef
+
+$(eval $(call BuildTarget))