summaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /target/linux/amazon/Makefile
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadmaster-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
master-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
master-31e0f0ae-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'target/linux/amazon/Makefile')
-rw-r--r--target/linux/amazon/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/amazon/Makefile b/target/linux/amazon/Makefile
index 1967d52f42..17f9d96494 100644
--- a/target/linux/amazon/Makefile
+++ b/target/linux/amazon/Makefile
@@ -10,6 +10,9 @@ ARCH:=mips
BOARD:=amazon
BOARDNAME:=Infineon Amazon
FEATURES:=squashfs jffs2 broken
+LINUX_VERSION:=2.6.21.5
+
+include $(INCLUDE_DIR)/target.mk
define Target/Description
Build firmware images for Infineon Amazon boards
@@ -17,9 +20,7 @@ endef
KERNELNAME:="uImage"
-include $(INCLUDE_DIR)/kernel-build.mk
-
# include the profiles
-include profiles/*.mk
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))