summaryrefslogtreecommitdiffstats
path: root/target/linux/amazon-2.6/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-07-23 22:10:11 +0000
committerJohn Crispin <john@openwrt.org>2007-07-23 22:10:11 +0000
commit7470547083506f15a893165e8e312a9bf4eac893 (patch)
treed996fa1661834d1fd45591bae6b977ad894c4530 /target/linux/amazon-2.6/image/Makefile
parentbee289741948605001e405bb1fdb92b60b36b17c (diff)
downloadmaster-31e0f0ae-7470547083506f15a893165e8e312a9bf4eac893.tar.gz
master-31e0f0ae-7470547083506f15a893165e8e312a9bf4eac893.tar.bz2
master-31e0f0ae-7470547083506f15a893165e8e312a9bf4eac893.zip
initial merge of infineon code for amazon, pci is still broken a bit. a big thank you goes to infineon for providing info and reference code
SVN-Revision: 8137
Diffstat (limited to 'target/linux/amazon-2.6/image/Makefile')
-rw-r--r--target/linux/amazon-2.6/image/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/amazon-2.6/image/Makefile b/target/linux/amazon-2.6/image/Makefile
new file mode 100644
index 0000000000..c749560db9
--- /dev/null
+++ b/target/linux/amazon-2.6/image/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ $(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -C lzma -a 0x80002000 -e \
+ 0x80002000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
+
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image)
+endef
+
+define Image/Build
+ cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))