summaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-03-28 18:18:38 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-03-28 18:18:38 +0000
commitf51f3ee9bc0ebd26b28fa7687cc4b7dd6dadc1b4 (patch)
treeaa8328b4022f79dba09d9d2ecab611ddf17e7124 /target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch
parent26cf81b94b22a3cc95676ff63e6d69dd256de080 (diff)
downloadmaster-31e0f0ae-f51f3ee9bc0ebd26b28fa7687cc4b7dd6dadc1b4.tar.gz
master-31e0f0ae-f51f3ee9bc0ebd26b28fa7687cc4b7dd6dadc1b4.tar.bz2
master-31e0f0ae-f51f3ee9bc0ebd26b28fa7687cc4b7dd6dadc1b4.zip
adm8668: add 3.18 support
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 45094
Diffstat (limited to 'target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch')
-rw-r--r--target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch b/target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch
new file mode 100644
index 0000000000..f7883cdb20
--- /dev/null
+++ b/target/linux/adm8668/patches-3.18/003-adm8668_nor_map.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -97,6 +97,12 @@ config MSP_FLASH_MAP_LIMIT
+ default "0x02000000"
+ depends on MSP_FLASH_MAP_LIMIT_32M
+
++config MTD_ADM8668_NOR
++ tristate "ADM8668 NOR mapping"
++ depends on ADM8668 && MTD_CFI
++ help
++ mapping driver for ADM8668 NOR
++
+ config MTD_SUN_UFLASH
+ tristate "Sun Microsystems userflash support"
+ depends on SPARC && MTD_CFI && PCI
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -43,3 +43,4 @@ obj-$(CONFIG_MTD_VMU) += vmu-flash.o
+ obj-$(CONFIG_MTD_GPIO_ADDR) += gpio-addr-flash.o
+ obj-$(CONFIG_MTD_LATCH_ADDR) += latch-addr-flash.o
+ obj-$(CONFIG_MTD_LANTIQ) += lantiq-flash.o
++obj-$(CONFIG_MTD_ADM8668_NOR) += adm8668.o