summaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-11-06 18:54:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-11-06 18:54:20 +0000
commitd9a42c5436a0bdc49696edaf80958cfa9a3f26cc (patch)
tree8426747c468d82fa0461445c9c616d536cd77534 /target/linux/adm8668/Makefile
parent1f8f2aaa37114460df167dda37260190e714e6fc (diff)
downloadmaster-31e0f0ae-d9a42c5436a0bdc49696edaf80958cfa9a3f26cc.tar.gz
master-31e0f0ae-d9a42c5436a0bdc49696edaf80958cfa9a3f26cc.tar.bz2
master-31e0f0ae-d9a42c5436a0bdc49696edaf80958cfa9a3f26cc.zip
Merge branch 'adm8668'
SVN-Revision: 23900
Diffstat (limited to 'target/linux/adm8668/Makefile')
-rw-r--r--target/linux/adm8668/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
new file mode 100644
index 0000000000..9021e39256
--- /dev/null
+++ b/target/linux/adm8668/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=adm8668
+BOARDNAME:=Infineon WildPass ADM8668
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.36
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
+# kmod-switch kmod-diag nvram
+
+define Target/Description
+ Build firmware images for Infineon WildPass (ADM8668) based routers
+ (e.g. T-Mobile branded Linksys WRTU54G-TM)
+endef
+
+$(eval $(call BuildTarget))