summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120eb-2.6
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-06-25 08:47:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-06-25 08:47:10 +0000
commitfcc5a6e25288d8cc0612b9b8f6eaa85dd7abd957 (patch)
tree8ebb77d9fda7de7b28b0ef3172bff6c2c17b69c5 /target/linux/adm5120eb-2.6
parent8c41e51e92fda935eb907b9263ae44a30f9977bc (diff)
downloadmaster-31e0f0ae-fcc5a6e25288d8cc0612b9b8f6eaa85dd7abd957.tar.gz
master-31e0f0ae-fcc5a6e25288d8cc0612b9b8f6eaa85dd7abd957.tar.bz2
master-31e0f0ae-fcc5a6e25288d8cc0612b9b8f6eaa85dd7abd957.zip
from now on, the lzma loader is able to pass parameters to the kernel
SVN-Revision: 7723
Diffstat (limited to 'target/linux/adm5120eb-2.6')
-rw-r--r--target/linux/adm5120eb-2.6/image/Makefile56
1 files changed, 32 insertions, 24 deletions
diff --git a/target/linux/adm5120eb-2.6/image/Makefile b/target/linux/adm5120eb-2.6/image/Makefile
index ce4644da17..0022b48448 100644
--- a/target/linux/adm5120eb-2.6/image/Makefile
+++ b/target/linux/adm5120eb-2.6/image/Makefile
@@ -7,18 +7,14 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+IMGNAME = $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
LOADER_MAKE = $(MAKE) -C lzma-loader KDIR=$(KDIR)
-define CompileLoader
- $(LOADER_MAKE) LOADER=$(1) LOADER_DATA="" \
- LZMA_TEXT_START=$(2) LZMA_STARTUP_ORG=$(3) \
- compile
-endef
-
-define CompileLZMAKernel
- $(LOADER_MAKE) LOADER=vmlinux-lzma-$(1) LOADER_DATA=$(KDIR)/vmlinux.lzma \
- LZMA_TEXT_START=$(2) LZMA_STARTUP_ORG=$(3) \
- compile
+define Image/Build/Loader
+ $(LOADER_MAKE) LOADER=loader-$(1).$(2) LOADER_DATA="" \
+ LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
+ CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
+ compile loader.$(2)
endef
define Build/Clean
@@ -27,11 +23,6 @@ endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- $(call CompileLoader,zyxel,0x80500000,0)
-else
- $(call CompileLZMAKernel,zyxel,0x80500000,0)
-endif
endef
define trxalign/jffs2-128k
@@ -44,25 +35,42 @@ define trxalign/squashfs
-a 1024
endef
+define Image/Build/TRX
+ $(STAGING_DIR)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
+ $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
+endef
+
+define Image/Build/TRXNoloader
+ $(STAGING_DIR)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
+ $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
+endef
+
define Image/Build/ZyXEL
- $(CP) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).trx
+ $(call Image/Build/Loader,loader-$(2),gz,0x80500000,0)
+ $(call Image/Build/TRXNoloader,$(IMGNAME)-$(3)-$(2).trx,$(1))
+ #TODO: firmware generation tool needed
endef
define Image/Build
- $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
-ifneq ($(1),jffs2-128K)
- #FIXME: firware images yet
-endif
+ #FIXME: No firmware images yet
endef
define Image/Build/LZMAKernel
- $(CP) $(KDIR)/loader-vmlinux-lzma-$(2).$(3) \
- $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux-lzma-$(1).$(3)
+ $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \
+ LOADER=openwrt-$(BOARD)-$(KERNEL)-ramfs-lzma-$(1).$(2) \
+ LOADER_DATA=$(KDIR)/vmlinux.lzma \
+ LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
+ CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
+ compile loader.$(2)
+endef
+
+define Image/Build/LZMAKernel/ZyXEL
+ $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0,y,$(1))
endef
define Image/Build/Initramfs
- $(call Image/Build/LZMAKernel,p-334wt,zyxel,bin)
- $(call Image/Build/LZMAKernel,p-335wt,zyxel,bin)
+ $(call Image/Build/LZMAKernel/Generic,p-334wt,bin)
+ $(call Image/Build/LZMAKernel/Generic,p-335,bin)
endef
$(eval $(call BuildImage))