summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120eb-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-16 09:56:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-16 09:56:32 +0000
commit10e8d517a5aa1f142fa9db12caea3d6da5e3495c (patch)
treef71d45d2ba3671cac0846b367afb9a44f9ff2e81 /target/linux/adm5120eb-2.6/image/Makefile
parent151babe684cafa123b416a9785b2a8cef83f6d03 (diff)
downloadmaster-31e0f0ae-10e8d517a5aa1f142fa9db12caea3d6da5e3495c.tar.gz
master-31e0f0ae-10e8d517a5aa1f142fa9db12caea3d6da5e3495c.tar.bz2
master-31e0f0ae-10e8d517a5aa1f142fa9db12caea3d6da5e3495c.zip
Add preliminary support for ADM5120 big-endian targets (Zyxel P-335WT for instance), thanks Gabor Juhos
SVN-Revision: 6964
Diffstat (limited to 'target/linux/adm5120eb-2.6/image/Makefile')
-rw-r--r--target/linux/adm5120eb-2.6/image/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/adm5120eb-2.6/image/Makefile b/target/linux/adm5120eb-2.6/image/Makefile
new file mode 100644
index 0000000000..82ecedc1d0
--- /dev/null
+++ b/target/linux/adm5120eb-2.6/image/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Compile
+ rm -f $(KDIR)/loader-zynos.gz $(KDIR)/loader-zynos.bin
+ $(MAKE) -C lzma-loader \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ LOADER=loader-zynos \
+ install
+endef
+
+define Build/Clean
+ $(MAKE) -C lzma-loader clean
+endef
+
+define Image/Prepare
+ cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+endef
+
+define trxalign/jffs2-128k
+-a 0x20000
+endef
+define trxalign/jffs2-64k
+-a 0x10000
+endef
+define trxalign/squashfs
+-a 1024
+endef
+
+define Image/Build/ZyXEL
+ $(CP) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).trx
+endef
+
+define Image/Build
+ $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+ifneq ($(1),jffs2-128K)
+ #FIXME: no supported boards yet
+endif
+endef
+
+$(eval $(call BuildImage))