summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/adm5120
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadmaster-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/adm5120')
-rw-r--r--target/linux/adm5120/image/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/target/linux/adm5120/image/Makefile b/target/linux/adm5120/image/Makefile
index 7ced198a21..4ca4d48568 100644
--- a/target/linux/adm5120/image/Makefile
+++ b/target/linux/adm5120/image/Makefile
@@ -21,14 +21,6 @@ fs_all:=all
fs_4k:=4k
fs_64k:=64k
fs_128k:=128k
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- fs_squash:=initramfs
- fs_all:=initramfs
- fs_4k:=initramfs
- fs_64k:=initramfs
- fs_128k:=initramfs
- VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
-endif
define Build/Clean
$(LOADER_MAKE) clean
@@ -111,6 +103,10 @@ endef
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
cp $(KDIR)/vmlinux $(VMLINUX).bin
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ cp $(KDIR)/vmlinux-initramfs.elf $(VMLINUX)-initramfs.elf
+ cp $(KDIR)/vmlinux $(VMLINUX)-initramfs.bin
+endif
endef
$(eval $(call BuildImage))