summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-01-02 05:12:46 +0000
committerAndy Boyett <agb@openwrt.org>2009-01-02 05:12:46 +0000
commit9f8c82da095869b7aadd6c95997ec9841eecee12 (patch)
treea1fe02e03aced1f09ab60c8d3d48859672946423 /target/linux/adm5120
parentcf8362db3c25850214e5be2b15e777359857d2a6 (diff)
downloadmaster-31e0f0ae-9f8c82da095869b7aadd6c95997ec9841eecee12.tar.gz
master-31e0f0ae-9f8c82da095869b7aadd6c95997ec9841eecee12.tar.bz2
master-31e0f0ae-9f8c82da095869b7aadd6c95997ec9841eecee12.zip
Add hostapd-mini to default images where applicable
SVN-Revision: 13819
Diffstat (limited to 'target/linux/adm5120')
-rw-r--r--target/linux/adm5120/Makefile8
-rw-r--r--target/linux/adm5120/router_le/profiles/Cellvision.mk16
-rw-r--r--target/linux/adm5120/router_le/profiles/Edimax.mk5
3 files changed, 19 insertions, 10 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index 9a601e47d5..4e63a0fcc9 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -15,11 +15,7 @@ INITRAMFS_EXTRA_FILES:=
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += admswconfig
-DEFAULT_PACKAGES += \
- kmod-input-core \
- kmod-input-polldev \
- kmod-input-gpio-buttons \
- kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+ kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
$(eval $(call BuildTarget))
diff --git a/target/linux/adm5120/router_le/profiles/Cellvision.mk b/target/linux/adm5120/router_le/profiles/Cellvision.mk
index 9c8356a663..9fa1e02330 100644
--- a/target/linux/adm5120/router_le/profiles/Cellvision.mk
+++ b/target/linux/adm5120/router_le/profiles/Cellvision.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,6 +8,7 @@
define Profile/CAS630
NAME:=Cellvision CAS-630 IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS630/Description
@@ -17,6 +18,7 @@ endef
define Profile/CAS630W
NAME:=Cellvision CAS-630W IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS630W/Description
@@ -26,6 +28,7 @@ endef
define Profile/CAS670
NAME:=Cellvision CAS-670 IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS670/Description
@@ -35,6 +38,7 @@ endef
define Profile/CAS670W
NAME:=Cellvision CAS-670W IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS670W/Description
@@ -44,6 +48,7 @@ endef
define Profile/CAS700
NAME:=Cellvision CAS-700 IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS700/Description
@@ -53,6 +58,7 @@ endef
define Profile/CAS700W
NAME:=Cellvision CAS-700W IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS700W/Description
@@ -61,7 +67,7 @@ endef
define Profile/CAS771
NAME:=Cellvision CAS-771 IP camera (Experimental)
- PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+ PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
endef
define Profile/CAS771/Description
@@ -70,7 +76,7 @@ endef
define Profile/CAS771W
NAME:=Cellvision CAS-771W IP camera (Experimental)
- PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
+ PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
endef
define Profile/CAS771W/Description
@@ -80,6 +86,7 @@ endef
define Profile/CAS790
NAME:=Cellvision CAS-790 IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS790/Description
@@ -89,6 +96,7 @@ endef
define Profile/CAS861
NAME:=Cellvision CAS-861 IP camera (Experimental)
# TODO: add default packages
+ PACKAGES:=-hostapd-mini
endef
define Profile/CAS861/Description
@@ -106,6 +114,7 @@ endef
define Profile/NFS101U
NAME:=Cellvision NFS-101U Network File Server (Experimental)
+ PACKAGES:=-hostapd-mini
endef
define Profile/NFS101U/Description
@@ -114,6 +123,7 @@ endef
define Profile/NFS101WU
NAME:=Cellvision NFS-101WU Network File Server (Experimental)
+ PACKAGES:=-hostapd-mini
endef
define Profile/NFS101WU/Description
diff --git a/target/linux/adm5120/router_le/profiles/Edimax.mk b/target/linux/adm5120/router_le/profiles/Edimax.mk
index e4c427f570..70b26534ef 100644
--- a/target/linux/adm5120/router_le/profiles/Edimax.mk
+++ b/target/linux/adm5120/router_le/profiles/Edimax.mk
@@ -7,6 +7,7 @@
define Profile/BR6104K
NAME:=Edimax BR-6104K (Unofficial)
+ PACKAGES:=-hostapd-mini
endef
define Profile/BR6104K/Description
@@ -15,7 +16,7 @@ endef
define Profile/BR6104KP
NAME:=Edimax BR-6104KP (Unofficial)
- PACKAGES:=kmod-usb-core kmod-usb-adm5120
+ PACKAGES:=-hostapd-mini kmod-usb-core kmod-usb-adm5120
endef
define Profile/BR6104KP/Description
@@ -24,6 +25,7 @@ endef
define Profile/BR6104WG
NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
+ PACKAGES:=-hostapd-mini
endef
define Profile/BR6104WG/Description
@@ -32,6 +34,7 @@ endef
define Profile/BR6114WG
NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
+ PACKAGES:=-hostapd-mini
endef
define Profile/BR6114WG/Description