summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-02-09 10:29:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-02-09 10:29:28 +0000
commitd187aba072246a4b03979b52b63198967cb511e6 (patch)
tree0e564d4fff61a6173e95cf1e26ff005dd47a5fa4 /target/linux/adm5120/patches/007-adm5120_pci.patch
parentcf02f1c6b20c64b88d51d0d6d5324ea6010583c7 (diff)
downloadmaster-31e0f0ae-d187aba072246a4b03979b52b63198967cb511e6.tar.gz
master-31e0f0ae-d187aba072246a4b03979b52b63198967cb511e6.tar.bz2
master-31e0f0ae-d187aba072246a4b03979b52b63198967cb511e6.zip
switch to 2.6.24
SVN-Revision: 10427
Diffstat (limited to 'target/linux/adm5120/patches/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches/007-adm5120_pci.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches/007-adm5120_pci.patch b/target/linux/adm5120/patches/007-adm5120_pci.patch
new file mode 100644
index 0000000000..bce0c814b9
--- /dev/null
+++ b/target/linux/adm5120/patches/007-adm5120_pci.patch
@@ -0,0 +1,23 @@
+Index: linux-2.6.24/arch/mips/pci/Makefile
+===================================================================
+--- linux-2.6.24.orig/arch/mips/pci/Makefile
++++ linux-2.6.24/arch/mips/pci/Makefile
+@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
+ obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
+ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
++obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o
+Index: linux-2.6.24/include/linux/pci_ids.h
+===================================================================
+--- linux-2.6.24.orig/include/linux/pci_ids.h
++++ linux-2.6.24/include/linux/pci_ids.h
+@@ -1703,6 +1703,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000