summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:36 +0000
commitedd36342e58da133b106ce6327fb5a02d5d30c1e (patch)
tree5eadbcade30c8370b2d236e4a84774380bf45247 /target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
parent92cd48e9eae68bf504b531b5c6bdc544ac595da3 (diff)
downloadmaster-31e0f0ae-edd36342e58da133b106ce6327fb5a02d5d30c1e.tar.gz
master-31e0f0ae-edd36342e58da133b106ce6327fb5a02d5d30c1e.tar.bz2
master-31e0f0ae-edd36342e58da133b106ce6327fb5a02d5d30c1e.zip
adm5120: add support for 3.6
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34951
Diffstat (limited to 'target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..c89e326bab
--- /dev/null
+++ b/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -555,4 +555,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -66,3 +66,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o