summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.6/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:36 +0000
commitedd36342e58da133b106ce6327fb5a02d5d30c1e (patch)
tree5eadbcade30c8370b2d236e4a84774380bf45247 /target/linux/adm5120/patches-3.6/003-adm5120_switch.patch
parent92cd48e9eae68bf504b531b5c6bdc544ac595da3 (diff)
downloadmaster-31e0f0ae-edd36342e58da133b106ce6327fb5a02d5d30c1e.tar.gz
master-31e0f0ae-edd36342e58da133b106ce6327fb5a02d5d30c1e.tar.bz2
master-31e0f0ae-edd36342e58da133b106ce6327fb5a02d5d30c1e.zip
adm5120: add support for 3.6
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34951
Diffstat (limited to 'target/linux/adm5120/patches-3.6/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-3.6/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.6/003-adm5120_switch.patch b/target/linux/adm5120/patches-3.6/003-adm5120_switch.patch
new file mode 100644
index 0000000000..c2f534b20e
--- /dev/null
+++ b/target/linux/adm5120/patches-3.6/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -244,6 +244,10 @@ source "drivers/net/dsa/Kconfig"
+
+ source "drivers/net/ethernet/Kconfig"
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ source "drivers/net/fddi/Kconfig"
+
+ source "drivers/net/hippi/Kconfig"
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -32,6 +32,7 @@ obj-$(CONFIG_CAN) += can/
+ obj-$(CONFIG_ETRAX_ETHERNET) += cris/
+ obj-$(CONFIG_NET_DSA) += dsa/
+ obj-$(CONFIG_ETHERNET) += ethernet/
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_FDDI) += fddi/
+ obj-$(CONFIG_HIPPI) += hippi/
+ obj-$(CONFIG_HAMRADIO) += hamradio/