summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2011-04-13 16:42:03 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2011-04-13 16:42:03 +0000
commit54d4dc56c50063e373c149495fed6809af6118fa (patch)
treec04bb2686eb473e1caeca1bad90f524a1ac222f2 /target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch
parent8ba2d8098a03edbc1b8cc9990be8977c98267e05 (diff)
downloadmaster-31e0f0ae-54d4dc56c50063e373c149495fed6809af6118fa.tar.gz
master-31e0f0ae-54d4dc56c50063e373c149495fed6809af6118fa.tar.bz2
master-31e0f0ae-54d4dc56c50063e373c149495fed6809af6118fa.zip
linux/adm5120: add 2.6.38 preliminary support
SVN-Revision: 26647
Diffstat (limited to 'target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..929becbc1e
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -457,4 +457,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -55,3 +55,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o