summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2011-04-13 16:42:03 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2011-04-13 16:42:03 +0000
commit54d4dc56c50063e373c149495fed6809af6118fa (patch)
treec04bb2686eb473e1caeca1bad90f524a1ac222f2 /target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch
parent8ba2d8098a03edbc1b8cc9990be8977c98267e05 (diff)
downloadmaster-31e0f0ae-54d4dc56c50063e373c149495fed6809af6118fa.tar.gz
master-31e0f0ae-54d4dc56c50063e373c149495fed6809af6118fa.tar.bz2
master-31e0f0ae-54d4dc56c50063e373c149495fed6809af6118fa.zip
linux/adm5120: add 2.6.38 preliminary support
SVN-Revision: 26647
Diffstat (limited to 'target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch
new file mode 100644
index 0000000000..30347ae0ca
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.38/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -494,6 +494,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -216,6 +216,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o