summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-04 17:45:05 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-04 17:45:05 +0000
commit7cb70cb2b8f2b3e31d3e86576141abb161593fb6 (patch)
tree66996ea1e9ed75cda833e663a45805a1e804360d /target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch
parent8ae1a4fc69b0155cd30b7d39977f782c1046e477 (diff)
downloadmaster-31e0f0ae-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.tar.gz
master-31e0f0ae-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.tar.bz2
master-31e0f0ae-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.zip
linux/adm5120: add preliminary 2.6.36 kernel support (refresh patches)
SVN-Revision: 23224
Diffstat (limited to 'target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..ec4f6c5a40
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o