summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
commit93993b29e0c89d87d13c022753739ebe953c1d19 (patch)
tree791dfbf8b9ce7c95be2ccafa14dce8316c69ce51 /target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
parent9bc1e548a19f05e2bafad0461b9ae0b34654cf2a (diff)
downloadmaster-31e0f0ae-93993b29e0c89d87d13c022753739ebe953c1d19.tar.gz
master-31e0f0ae-93993b29e0c89d87d13c022753739ebe953c1d19.tar.bz2
master-31e0f0ae-93993b29e0c89d87d13c022753739ebe953c1d19.zip
adm5120: add kernel 2.6.35 preliminary support
SVN-Revision: 21751
Diffstat (limited to 'target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..0258fa4fbe
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -365,4 +365,12 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o