summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
commit066358ab8036321a9c333a881ba329985e688dfd (patch)
tree4d6a6ef78043d87b6da5d7cbfd5a51d744e5f205 /target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch
parentcde7b6363c77be3d6e81e9444ac5d2ba8d0db87f (diff)
downloadmaster-31e0f0ae-066358ab8036321a9c333a881ba329985e688dfd.tar.gz
master-31e0f0ae-066358ab8036321a9c333a881ba329985e688dfd.tar.bz2
master-31e0f0ae-066358ab8036321a9c333a881ba329985e688dfd.zip
adm5120: add 2.6.33 & 2.6.34 kernel support
SVN-Revision: 21182
Diffstat (limited to 'target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch
new file mode 100644
index 0000000000..cf6350c8cb
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.34/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -602,6 +602,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -208,6 +208,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o