summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
commit066358ab8036321a9c333a881ba329985e688dfd (patch)
tree4d6a6ef78043d87b6da5d7cbfd5a51d744e5f205 /target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
parentcde7b6363c77be3d6e81e9444ac5d2ba8d0db87f (diff)
downloadmaster-31e0f0ae-066358ab8036321a9c333a881ba329985e688dfd.tar.gz
master-31e0f0ae-066358ab8036321a9c333a881ba329985e688dfd.tar.bz2
master-31e0f0ae-066358ab8036321a9c333a881ba329985e688dfd.zip
adm5120: add 2.6.33 & 2.6.34 kernel support
SVN-Revision: 21182
Diffstat (limited to 'target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..69f1035505
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o