summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
commit89f3773ca4b4e278728ccf83e29e5bf117484663 (patch)
tree6bf5f02cf46042e7e0d8064dbb3352aec869adce /target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch
parente16f20b51813c4ef7d2519235d45fa37bd09e2ac (diff)
downloadmaster-31e0f0ae-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.gz
master-31e0f0ae-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.bz2
master-31e0f0ae-89f3773ca4b4e278728ccf83e29e5bf117484663.zip
adm5120: preliminary 2.6.32 support (closes: #6304)
SVN-Revision: 19005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch b/target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch
new file mode 100644
index 0000000000..8b5a553479
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.32/005-adm5120_usb.patch
@@ -0,0 +1,33 @@
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -9,6 +9,7 @@ obj-$(CONFIG_USB) += core/
+ obj-$(CONFIG_USB_MON) += mon/
+
+ obj-$(CONFIG_PCI) += host/
++obj-$(CONFIG_USB_ADM5120_HCD) += host/
+ obj-$(CONFIG_USB_EHCI_HCD) += host/
+ obj-$(CONFIG_USB_ISP116X_HCD) += host/
+ obj-$(CONFIG_USB_OHCI_HCD) += host/
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -4,6 +4,10 @@
+ comment "USB Host Controller Drivers"
+ depends on USB
+
++config USB_ADM5120_HCD
++ tristate "ADM5120 HCD support (EXPERIMENTAL)"
++ depends on USB && ADM5120 && EXPERIMENTAL
++
+ config USB_C67X00_HCD
+ tristate "Cypress C67x00 HCD support"
+ depends on USB
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_USB_WHCI_HCD) += whci/
+
+ obj-$(CONFIG_PCI) += pci-quirks.o
+
++obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
+ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o