summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
commit89f3773ca4b4e278728ccf83e29e5bf117484663 (patch)
tree6bf5f02cf46042e7e0d8064dbb3352aec869adce /target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch
parente16f20b51813c4ef7d2519235d45fa37bd09e2ac (diff)
downloadmaster-31e0f0ae-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.gz
master-31e0f0ae-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.bz2
master-31e0f0ae-89f3773ca4b4e278728ccf83e29e5bf117484663.zip
adm5120: preliminary 2.6.32 support (closes: #6304)
SVN-Revision: 19005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch
new file mode 100644
index 0000000000..e3d63ab05f
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.32/002-adm5120_flash.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -557,4 +557,8 @@ config MTD_VMU
+ To build this as a module select M here, the module will be called
+ vmu-flash.
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on ADM5120
++
+ endmenu
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -41,6 +41,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
+ obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o