summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
commitd31a7b51abc91241870e907ff76ce7058aceefa1 (patch)
tree920f2dabb56d1bae95a670b63ff37ef2ae33f68f /target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch
parentc28af661ee0a71d7964358a41d19dcc86737f19b (diff)
downloadmaster-31e0f0ae-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.gz
master-31e0f0ae-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.bz2
master-31e0f0ae-d31a7b51abc91241870e907ff76ce7058aceefa1.zip
add experimental support for 2.6.30
SVN-Revision: 15979
Diffstat (limited to 'target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..bb5e613d95
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.30/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -713,6 +713,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -105,6 +105,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+
+ # PARISC Architecture
+