summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
commitd31a7b51abc91241870e907ff76ce7058aceefa1 (patch)
tree920f2dabb56d1bae95a670b63ff37ef2ae33f68f /target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch
parentc28af661ee0a71d7964358a41d19dcc86737f19b (diff)
downloadmaster-31e0f0ae-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.gz
master-31e0f0ae-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.bz2
master-31e0f0ae-d31a7b51abc91241870e907ff76ce7058aceefa1.zip
add experimental support for 2.6.30
SVN-Revision: 15979
Diffstat (limited to 'target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch
new file mode 100644
index 0000000000..771dd5f807
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.30/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -612,6 +612,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -195,6 +195,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o