summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit4e8b080d9f7819ee9bb77cdb8215462acc1759f9 (patch)
treeefad7bd1b41a2d96ff842eaa6ef2c5f241ff943d /target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch
parent9a74dd2faae85d00c5e669fce947aec8eb1f0dfb (diff)
downloadmaster-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.gz
master-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.bz2
master-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.zip
preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
SVN-Revision: 14189
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..2346009f8d
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -696,6 +696,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+
+ # PARISC Architecture
+