summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit4e8b080d9f7819ee9bb77cdb8215462acc1759f9 (patch)
treeefad7bd1b41a2d96ff842eaa6ef2c5f241ff943d /target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch
parent9a74dd2faae85d00c5e669fce947aec8eb1f0dfb (diff)
downloadmaster-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.gz
master-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.bz2
master-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.zip
preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
SVN-Revision: 14189
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch b/target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch
new file mode 100644
index 0000000000..75cd81b791
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/005-adm5120_usb.patch
@@ -0,0 +1,33 @@
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_USB_SL811_HCD) += host/
+ obj-$(CONFIG_USB_U132_HCD) += host/
+ obj-$(CONFIG_USB_R8A66597_HCD) += host/
+ obj-$(CONFIG_USB_HWA_HCD) += host/
++obj-$(CONFIG_USB_ADM5120_HCD) += host/
+
+ obj-$(CONFIG_USB_C67X00_HCD) += c67x00/
+
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -4,6 +4,10 @@
+ comment "USB Host Controller Drivers"
+ depends on USB
+
++config USB_ADM5120_HCD
++ tristate "ADM5120 HCD support (EXPERIMENTAL)"
++ depends on USB && ADM5120 && EXPERIMENTAL
++
+ config USB_C67X00_HCD
+ tristate "Cypress C67x00 HCD support"
+ depends on USB
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_USB_WHCI_HCD) += whci/
+
+ obj-$(CONFIG_PCI) += pci-quirks.o
+
++obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
+ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
+ obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o