summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit4e8b080d9f7819ee9bb77cdb8215462acc1759f9 (patch)
treeefad7bd1b41a2d96ff842eaa6ef2c5f241ff943d /target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
parent9a74dd2faae85d00c5e669fce947aec8eb1f0dfb (diff)
downloadmaster-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.gz
master-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.bz2
master-31e0f0ae-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.zip
preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
SVN-Revision: 14189
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
new file mode 100644
index 0000000000..16470704a6
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/002-adm5120_flash.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -540,5 +540,9 @@ config MTD_PLATRAM
+
+ This selection automatically selects the map_ram driver.
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on ADM5120
++
+ endmenu
+
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
+ obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o