summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-05 11:07:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-05 11:07:49 +0000
commit6bfeb815486de741db535b4c93b5d7f9aeb2b3c5 (patch)
treebae2ae6fa978380296314c293f739989f470d561 /target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch
parenteed889b77b94c7d0a22a5d2e3fc3f2956386f5b9 (diff)
downloadmaster-31e0f0ae-6bfeb815486de741db535b4c93b5d7f9aeb2b3c5.tar.gz
master-31e0f0ae-6bfeb815486de741db535b4c93b5d7f9aeb2b3c5.tar.bz2
master-31e0f0ae-6bfeb815486de741db535b4c93b5d7f9aeb2b3c5.zip
experimental support for 2.6.27
SVN-Revision: 12863
Diffstat (limited to 'target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..8c93912e0a
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.27/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -653,6 +653,18 @@
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -102,6 +102,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+
+ # PARISC Architecture
+