summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-20 07:45:08 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-20 07:45:08 +0000
commitd2cfb2934f7f93ddf102b16eeeaf35a1324016bf (patch)
treed589abbc8095d2dab50ae9212a10b093db207536 /target/linux/adm5120/patches-2.6.23
parent4c093ed622ac073ace448abfcc13d96ebf18e091 (diff)
downloadmaster-31e0f0ae-d2cfb2934f7f93ddf102b16eeeaf35a1324016bf.tar.gz
master-31e0f0ae-d2cfb2934f7f93ddf102b16eeeaf35a1324016bf.tar.bz2
master-31e0f0ae-d2cfb2934f7f93ddf102b16eeeaf35a1324016bf.zip
add LEDs trigger for switch port states, thanks to Bernhard Held (closes: #2153)
SVN-Revision: 9362
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23')
-rw-r--r--target/linux/adm5120/patches-2.6.23/009-adm5120_leds_switch_trigger.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.23/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..088b6223a1
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,26 @@
+Index: linux-2.6.23/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.23.orig/drivers/leds/Kconfig
++++ linux-2.6.23/drivers/leds/Kconfig
+@@ -152,4 +152,12 @@ config LEDS_TRIGGER_MORSE
+ tristate "LED Morse Trigger"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && LEDS_ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+Index: linux-2.6.23/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.23.orig/drivers/leds/Makefile
++++ linux-2.6.23/drivers/leds/Makefile
+@@ -24,3 +24,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o