summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-12-11 09:00:06 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-12-11 09:00:06 +0000
commitbb6c1aa770389f296e5efe41a5bf258c98e52284 (patch)
treea0d61b91fa004735999dee5ae20c7503baff0838 /target/linux/adm5120/patches-2.6.23
parent71f1ca2cba29516d42f9685293bf72f6b8295398 (diff)
downloadmaster-31e0f0ae-bb6c1aa770389f296e5efe41a5bf258c98e52284.tar.gz
master-31e0f0ae-bb6c1aa770389f296e5efe41a5bf258c98e52284.tar.bz2
master-31e0f0ae-bb6c1aa770389f296e5efe41a5bf258c98e52284.zip
new experimental driver for the CF slot on the RouterBOARD 153
SVN-Revision: 9707
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23')
-rw-r--r--target/linux/adm5120/patches-2.6.23/120-rb153_cf_driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/120-rb153_cf_driver.patch b/target/linux/adm5120/patches-2.6.23/120-rb153_cf_driver.patch
new file mode 100644
index 0000000000..6bd6110768
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/120-rb153_cf_driver.patch
@@ -0,0 +1,26 @@
+--- linux-2.6.23.9/drivers/ata/Makefile.orig 2007-11-26 18:51:43.000000000 +0100
++++ linux-2.6.23.9/drivers/ata/Makefile 2007-12-08 18:15:07.000000000 +0100
+@@ -63,6 +63,7 @@
+ obj-$(CONFIG_PATA_SCC) += pata_scc.o
+ obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
+ obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
++obj-$(CONFIG_PATA_RB153_CF) += pata_rb153_cf.o
+ # Should be last but one libata driver
+ obj-$(CONFIG_ATA_GENERIC) += ata_generic.o
+ # Should be last libata driver
+--- linux-2.6.23.9/drivers/ata/Kconfig.orig 2007-11-26 18:51:43.000000000 +0100
++++ linux-2.6.23.9/drivers/ata/Kconfig 2007-12-08 18:16:43.000000000 +0100
+@@ -596,4 +596,13 @@
+
+ If unsure, say N.
+
++config PATA_RB153_CF
++ tristate "RouterBOARD 153 Compact Flash support"
++ depends on MIPS_ADM5120
++ help
++ This option enables support for a Compact Flash connected on
++ the RouterBOARD 153.
++
++ If unsure, say N.
++
+ endif # ATA