summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-10-22 20:56:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-10-22 20:56:34 +0000
commit2a0ca50ce2fbc3fc5b0eab9e48c08b46f0b7aa54 (patch)
treeb78e86a8da696710637c45773eea65e3649a9cbe /target/linux/adm5120/patches-2.6.23
parent5db86fb47a934a9afbe6d960a67ac1821be6dd74 (diff)
downloadmaster-31e0f0ae-2a0ca50ce2fbc3fc5b0eab9e48c08b46f0b7aa54.tar.gz
master-31e0f0ae-2a0ca50ce2fbc3fc5b0eab9e48c08b46f0b7aa54.tar.bz2
master-31e0f0ae-2a0ca50ce2fbc3fc5b0eab9e48c08b46f0b7aa54.zip
Add preliminary support for the Routerboard 153 CF slot (#2550)
SVN-Revision: 9403
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23')
-rw-r--r--target/linux/adm5120/patches-2.6.23/120-cf.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/120-cf.patch b/target/linux/adm5120/patches-2.6.23/120-cf.patch
new file mode 100644
index 0000000000..cbfe42d6c3
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/120-cf.patch
@@ -0,0 +1,31 @@
+Index: linux-2.6.23/drivers/block/Kconfig
+===================================================================
+--- linux-2.6.23/drivers/block/Kconfig 2007-10-09 22:31:38.000000000 +0200
++++ linux-2.6.23.new/drivers/block/Kconfig 2007-10-22 18:07:49.000000000 +0200
+@@ -65,6 +65,14 @@
+ To compile this driver as a module, choose M here: the
+ module will be called z2ram.
+
++config BLK_DEV_CF_MIPS
++ bool "CF slot of RB153 board"
++ depends on MIPS_ADM5120
++ default y
++ help
++ The Routerboard 153 has a CF slot on it. Enable the special block
++ device driver for it.
++
+ config BLK_DEV_XD
+ tristate "XT hard disk support"
+ depends on ISA && ISA_DMA_API
+Index: linux-2.6.23/drivers/block/Makefile
+===================================================================
+--- linux-2.6.23/drivers/block/Makefile 2007-10-09 22:31:38.000000000 +0200
++++ linux-2.6.23.new/drivers/block/Makefile.new 2007-10-22 18:08:15.000000000 +0200
+@@ -7,6 +7,7 @@
+
+ obj-$(CONFIG_MAC_FLOPPY) += swim3.o
+ obj-$(CONFIG_BLK_DEV_FD) += floppy.o
++obj-$(CONFIG_BLK_DEV_CF_MIPS) += rb1xx/
+ obj-$(CONFIG_AMIGA_FLOPPY) += amiflop.o
+ obj-$(CONFIG_PS3_DISK) += ps3disk.o
+ obj-$(CONFIG_ATARI_FLOPPY) += ataflop.o