summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-26 07:51:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-26 07:51:49 +0000
commitd29af25874381a4f325cf459a81357738f83e427 (patch)
tree2c22aab1a7a5e2861fcfc417b00921373ae14756 /target/linux/adm5120/image
parent41815ee5c8e09f3d3fca0e38045d99f9f4da5e12 (diff)
downloadmaster-31e0f0ae-d29af25874381a4f325cf459a81357738f83e427.tar.gz
master-31e0f0ae-d29af25874381a4f325cf459a81357738f83e427.tar.bz2
master-31e0f0ae-d29af25874381a4f325cf459a81357738f83e427.zip
reduce wasted flash space by ~56K on Edimax devices, thanks to Bernhard Held (closes: #2549)
SVN-Revision: 9450
Diffstat (limited to 'target/linux/adm5120/image')
-rw-r--r--target/linux/adm5120/image/router_le.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
index ec7673f6e3..0fc6309407 100644
--- a/target/linux/adm5120/image/router_le.mk
+++ b/target/linux/adm5120/image/router_le.mk
@@ -14,13 +14,14 @@ define Image/Build/Edimax
$(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
$(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
$(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
- -r $(KDIR)/loader-$(2).gz \
+ -r $(KDIR)/loader-$(2).gz::8192 \
-x $(call imgname,$(1),$(2)).trx \
$(call imgname,$(1),$(2))-webui.bin
$(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d \
- -r $(KDIR)/loader-$(2).gz \
+ -r $(KDIR)/loader-$(2).gz::8192 \
-x $(call imgname,$(1),$(2)).trx \
$(call imgname,$(1),$(2))-xmodem.bin
+ rm -f $(call imgname,$(1),$(2)).trx
endef
define Image/Build/Infineon