summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-05 14:50:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-05 14:50:53 +0000
commitbcdd5d9b14847fef0cb566c0022d4cd1919a8ee5 (patch)
treeeff64e929c9f37304198dc1eb518032c8e0bafec /target/linux/adm5120/image
parent8c47e7b84283dd2bd95a564a4b5043c735083213 (diff)
downloadmaster-31e0f0ae-bcdd5d9b14847fef0cb566c0022d4cd1919a8ee5.tar.gz
master-31e0f0ae-bcdd5d9b14847fef0cb566c0022d4cd1919a8ee5.tar.bz2
master-31e0f0ae-bcdd5d9b14847fef0cb566c0022d4cd1919a8ee5.zip
Edimax BR-6104K/KP specific fixes * add profile for Edimax BR-6104KP which contains the experimental USB driver by default * generate CSYS style images which are uploadable via ADMBoot/TFTPBoot (saves 64KB of space) * update kernel configuration
SVN-Revision: 9141
Diffstat (limited to 'target/linux/adm5120/image')
-rw-r--r--target/linux/adm5120/image/router_le.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
index 9f1aa9b2be..f910971599 100644
--- a/target/linux/adm5120/image/router_le.mk
+++ b/target/linux/adm5120/image/router_le.mk
@@ -16,7 +16,11 @@ define Image/Build/Edimax
$(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
-r $(KDIR)/loader-$(2).gz \
-x $(call imgname,$(1),$(2)).trx \
- $(call imgname,$(1),$(2)).bin
+ $(call imgname,$(1),$(2))-webui.bin
+ $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d \
+ -r $(KDIR)/loader-$(2).gz \
+ -x $(call imgname,$(1),$(2)).trx \
+ $(call imgname,$(1),$(2))-xmodem.bin
endef
define Image/Build/Infineon
@@ -195,10 +199,6 @@ define Image/Build/Board/BR6104K/squashfs
$(call Image/Build/Board/BR6104K,squashfs)
endef
-define Image/Build/Board/BR6104K/jffs2-64k
- $(call Image/Build/Board/BR6104K,jffs2-64k)
-endef
-
define Image/Build/Board/BR6104K/Initramfs
$(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
endef
@@ -308,6 +308,10 @@ define Image/Build/Profile/CAS771W
$(call Image/Build/Board/CAS771W/$(1))
endef
+define Image/Build/Profile/BR6104KP
+ $(call Image/Build/Board/BR6104K/$(1))
+endef
+
define Image/Build/Profile/RouterBoard
$(call Image/Build/Board/RB1xx/$(1))
endef