summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-02 09:09:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-02 09:09:55 +0000
commit58fcfa7ea057045d19aad1050e5f21789503768b (patch)
tree6ec2d49c636b743ed8d1e5ee0a03631f3247dc2d /target/linux/adm5120/image
parentb3ab6c458d859747f65317cfee2f2f270ff57382 (diff)
downloadmaster-31e0f0ae-58fcfa7ea057045d19aad1050e5f21789503768b.tar.gz
master-31e0f0ae-58fcfa7ea057045d19aad1050e5f21789503768b.tar.bz2
master-31e0f0ae-58fcfa7ea057045d19aad1050e5f21789503768b.zip
make image names shorten
SVN-Revision: 9089
Diffstat (limited to 'target/linux/adm5120/image')
-rw-r--r--target/linux/adm5120/image/Makefile4
-rw-r--r--target/linux/adm5120/image/router_le.mk11
2 files changed, 8 insertions, 7 deletions
diff --git a/target/linux/adm5120/image/Makefile b/target/linux/adm5120/image/Makefile
index ba3dd38f7e..710e82be5c 100644
--- a/target/linux/adm5120/image/Makefile
+++ b/target/linux/adm5120/image/Makefile
@@ -12,7 +12,7 @@ IMGNAME := $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
JFFS2EOF := $(KDIR)/jffs2.eof
define imgname
-$(IMGNAME)-$(patsubst jffs2-%,jffs2,$(1))-$(2)
+$(IMGNAME)-$(2)-$(patsubst jffs2-%,jffs2,$(1))
endef
define Build/Clean
@@ -35,7 +35,7 @@ endef
define Image/Build/LZMAKernel
$(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \
- LOADER=openwrt-$(BOARD)-$(KERNEL)-ramfs-lzma-$(1).$(2) \
+ LOADER=openwrt-$(BOARD)-$(KERNEL)-$(1)-ramfs.$(2) \
LOADER_DATA=$(KDIR)/vmlinux.lzma \
LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
index 54b9c4adca..be70ed21a5 100644
--- a/target/linux/adm5120/image/router_le.mk
+++ b/target/linux/adm5120/image/router_le.mk
@@ -226,7 +226,7 @@ endef
# Mikrotik RB-1xx
#
define Image/Build/Board/RB1xx/Initramfs
- $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-ramfs-rb1xx.elf
+ $(CP) $(KDIR)/vmlinux.elf $(call imgname,netboot,rb1xx)
endef
#
@@ -266,6 +266,7 @@ define Image/Build/Group/All
$(call Image/Build/Group/Edimax,$(1))
$(call Image/Build/Group/Cellvision,$(1))
$(call Image/Build/Group/Infineon,$(1))
+ $(call Image/Build/Board/RB1xx/$(1))
endef
#
@@ -311,14 +312,14 @@ define Image/Build/Profile/RouterBoard
$(call Image/Build/Board/RB1xx/$(1))
endef
-ifeq ($(PROFILE),Routerboard)
+ifeq ($(PROFILE),RouterBoard)
define Image/cmdline/yaffs2
- root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+ root=/dev/mtdblock3 rootfstype=yaffs2 init=/etc/preinit
endef
define Image/BuildKernel/RouterBoard
- $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-rb1xx-vmlinux
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux.elf \
+ $(CP) $(KDIR)/vmlinux.elf $(call imgname,kernel,rb1xx)
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(call imgname,kernel,rb1xx) \
'$(strip $(call Image/cmdline/yaffs2))'
endef